summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCameron Katri <me@cameronkatri.com>2021-10-06 14:37:26 -0400
committerCameron Katri <me@cameronkatri.com>2021-10-06 14:37:26 -0400
commite1bf4a0b92e6b7ccaa3e4e16ac8b1006d1038b45 (patch)
tree506b6f7308ceee214470252e4892539881c529f0
parent0678403d9c7218138c2bc5cbf1bd92cc4d450adc (diff)
downloadfreebsd-ports-e1bf4a0b92e6b7ccaa3e4e16ac8b1006d1038b45.tar.gz
freebsd-ports-e1bf4a0b92e6b7ccaa3e4e16ac8b1006d1038b45.tar.zst
freebsd-ports-e1bf4a0b92e6b7ccaa3e4e16ac8b1006d1038b45.zip
games/multimc: Fix buildmain
-rw-r--r--games/multimc/files/patch-libraries_javacheck_CMakeLists.txt11
-rw-r--r--games/multimc/files/patch-libraries_launcher_CMakeLists.txt11
2 files changed, 22 insertions, 0 deletions
diff --git a/games/multimc/files/patch-libraries_javacheck_CMakeLists.txt b/games/multimc/files/patch-libraries_javacheck_CMakeLists.txt
new file mode 100644
index 0000000..e68760d
--- /dev/null
+++ b/games/multimc/files/patch-libraries_javacheck_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- libraries/javacheck/CMakeLists.txt.orig 2021-10-06 18:04:26 UTC
++++ libraries/javacheck/CMakeLists.txt
+@@ -4,7 +4,7 @@ find_package(Java 1.6 REQUIRED COMPONENTS Development)
+
+ include(UseJava)
+ set(CMAKE_JAVA_JAR_ENTRY_POINT JavaCheck)
+-set(CMAKE_JAVA_COMPILE_FLAGS -target 1.6 -source 1.6 -Xlint:deprecation -Xlint:unchecked)
++set(CMAKE_JAVA_COMPILE_FLAGS -target 1.7 -source 1.7 -Xlint:deprecation -Xlint:unchecked)
+
+ set(SRC
+ JavaCheck.java
diff --git a/games/multimc/files/patch-libraries_launcher_CMakeLists.txt b/games/multimc/files/patch-libraries_launcher_CMakeLists.txt
new file mode 100644
index 0000000..8578570
--- /dev/null
+++ b/games/multimc/files/patch-libraries_launcher_CMakeLists.txt
@@ -0,0 +1,11 @@
+--- libraries/launcher/CMakeLists.txt.orig 2021-10-06 18:04:41 UTC
++++ libraries/launcher/CMakeLists.txt
+@@ -4,7 +4,7 @@ find_package(Java 1.6 REQUIRED COMPONENTS Development)
+
+ include(UseJava)
+ set(CMAKE_JAVA_JAR_ENTRY_POINT org.multimc.EntryPoint)
+-set(CMAKE_JAVA_COMPILE_FLAGS -target 1.6 -source 1.6 -Xlint:deprecation -Xlint:unchecked)
++set(CMAKE_JAVA_COMPILE_FLAGS -target 1.7 -source 1.7 -Xlint:deprecation -Xlint:unchecked)
+
+ set(SRC
+ org/multimc/EntryPoint.java