summaryrefslogtreecommitdiffstats
path: root/games/multimc/files/patch-CMakeLists.txt
diff options
context:
space:
mode:
authorCameron Katri <me@cameronkatri.com>2021-07-16 10:16:01 -0400
committerCameron Katri <me@cameronkatri.com>2021-07-16 10:16:01 -0400
commit8a1b679969245ed7944ca397b5a9df4370166b68 (patch)
tree355641dbc9d8e351929a54a31a17d605ff6b8d56 /games/multimc/files/patch-CMakeLists.txt
parent1dbd8d488ab44da4daea2a36d251d04f0bb7db70 (diff)
downloadfreebsd-ports-8a1b679969245ed7944ca397b5a9df4370166b68.tar.gz
freebsd-ports-8a1b679969245ed7944ca397b5a9df4370166b68.tar.zst
freebsd-ports-8a1b679969245ed7944ca397b5a9df4370166b68.zip
Add multimc with patch to autodetect minecraft-runtime
Diffstat (limited to 'games/multimc/files/patch-CMakeLists.txt')
-rw-r--r--games/multimc/files/patch-CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/games/multimc/files/patch-CMakeLists.txt b/games/multimc/files/patch-CMakeLists.txt
new file mode 100644
index 0000000..4769c4d
--- /dev/null
+++ b/games/multimc/files/patch-CMakeLists.txt
@@ -0,0 +1,12 @@
+--- CMakeLists.txt.orig 2019-07-13 18:18:48 UTC
++++ CMakeLists.txt
+@@ -38,6 +38,9 @@ if(UNIX AND APPLE)
+ endif()
+ set(CMAKE_CXX_FLAGS_DEBUG "${CMAKE_CXX_FLAGS_DEBUG} -Werror=return-type")
+
++# Fix build with Qt 5.13
++set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DQT_NO_DEPRECATED_WARNINGS=Y")
++
+ ##################################### Set Application options #####################################
+
+ ######## Set URLs ########