summaryrefslogtreecommitdiffstats
path: root/games/lwjgl3/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/lwjgl3/Makefile')
-rw-r--r--games/lwjgl3/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/games/lwjgl3/Makefile b/games/lwjgl3/Makefile
index c4e0978..cb46f42 100644
--- a/games/lwjgl3/Makefile
+++ b/games/lwjgl3/Makefile
@@ -4,21 +4,20 @@ PORTNAME= lwjgl3
DISTVERSION= 3.2.2
DISTVERSIONSUFFIX= -full
CATEGORIES= games java
-MASTER_SITES= https://github.com/CRKatri/lwjgl3/releases/download/${DISTVERSION}-freebsd-1/
+MASTER_SITES= https://github.com/CRKatri/lwjgl3/releases/download/${DISTVERSION}-freebsd-3/
MAINTAINER= me@cameronkatri.com
COMMENT= Lightweight Java Game Library 3
LICENSE= BSD3CLAUSE
-BUILD_DEPENDS= ${LOCALBASE}/lib/libdyncall_s.a:devel/dyncall \
- pkg-config:devel/pkgconf
+BUILD_DEPENDS= ${LOCALBASE}/lib/libdyncall_s.a:devel/dyncall
LIB_DEPENDS= libglfw.so:graphics/glfw \
libopenal.so:audio/openal-soft \
libopus.so:audio/opus \
libOpenCL.so:devel/ocl-icd
-USES= gl gnome xorg
+USES= gl gnome xorg pkgconfig
USE_ANT= yes
USE_GL= gl egl glesv2
USE_GNOME= gtk30 glib20