summaryrefslogtreecommitdiffstats
path: root/games/multimc/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'games/multimc/Makefile')
-rw-r--r--games/multimc/Makefile36
1 files changed, 36 insertions, 0 deletions
diff --git a/games/multimc/Makefile b/games/multimc/Makefile
new file mode 100644
index 0000000..5245a7c
--- /dev/null
+++ b/games/multimc/Makefile
@@ -0,0 +1,36 @@
+PORTNAME= multimc
+DISTVERSION= 0.6.12
+CATEGORIES= games java
+
+MAINTAINER= me@cameronkatri.com
+COMMENT= Minecraft launcher with the ability to manage multiple instances
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/COPYING.md
+
+RUN_DEPENDS= lwjgl>=2.9.3:games/lwjgl \
+ ${JAVAJARDIR}/lwjgl3/lwjgl.jar:games/lwjgl3
+
+USES= cmake compiler:c++14-lang qt:5
+USE_GITHUB= yes
+GH_ACCOUNT= MultiMC
+GH_PROJECT= MultiMC5
+GH_TUPLE= MultiMC:libnbtplusplus:508eda8:libnbtplusplus/libraries/libnbtplusplus \
+ MultiMC:quazip:3691d57:quazip/libraries/quazip
+USE_LDCONFIG= yes
+USE_JAVA= 1.8+
+USE_QT= core concurrent gui network testlib_build widgets xml \
+ buildtools_build qmake_build
+
+CMAKE_ARGS= -DMultiMC_LAYOUT="lin-system"
+CXXFLAGS+= -Wno-inconsistent-missing-override \
+ -Wno-delete-non-virtual-dtor \
+ -DLWJGL_DIR='\"${LOCALBASE}/lib/lwjgl\"'
+
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libMultiMC_*.so
+ ${INSTALL_DATA} ${WRKSRC}/application/package/linux/${PORTNAME}.desktop ${STAGEDIR}${PREFIX}/share/applications/
+ ${MKDIR} ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps/${PORTNAME}.svg
+ ${INSTALL_DATA} ${WRKSRC}/application/resources/multimc/scalable/multimc.svg ${STAGEDIR}${PREFIX}/share/icons/hicolor/scalable/apps/${PORTNAME}.svg
+
+.include <bsd.port.mk>