aboutsummaryrefslogtreecommitdiffstats
path: root/patch_cmds/diffstat/package/diffstat.spec
diff options
context:
space:
mode:
authorCameron Katri <me@cameronkatri.com>2021-05-09 14:20:58 -0400
committerCameron Katri <me@cameronkatri.com>2021-05-09 14:20:58 -0400
commit5fd83771641d15c418f747bd343ba6738d3875f7 (patch)
tree5abf0f78f680d9837dbd93d4d4c3933bb7509599 /patch_cmds/diffstat/package/diffstat.spec
downloadapple_cmds-5fd83771641d15c418f747bd343ba6738d3875f7.tar.gz
apple_cmds-5fd83771641d15c418f747bd343ba6738d3875f7.tar.zst
apple_cmds-5fd83771641d15c418f747bd343ba6738d3875f7.zip
Import macOS userland
adv_cmds-176 basic_cmds-55 bootstrap_cmds-116.100.1 developer_cmds-66 diskdev_cmds-667.40.1 doc_cmds-53.60.1 file_cmds-321.40.3 mail_cmds-35 misc_cmds-34 network_cmds-606.40.1 patch_cmds-17 remote_cmds-63 shell_cmds-216.60.1 system_cmds-880.60.2 text_cmds-106
Diffstat (limited to 'patch_cmds/diffstat/package/diffstat.spec')
-rw-r--r--patch_cmds/diffstat/package/diffstat.spec54
1 files changed, 54 insertions, 0 deletions
diff --git a/patch_cmds/diffstat/package/diffstat.spec b/patch_cmds/diffstat/package/diffstat.spec
new file mode 100644
index 0000000..99e91fe
--- /dev/null
+++ b/patch_cmds/diffstat/package/diffstat.spec
@@ -0,0 +1,54 @@
+Summary: diffstat - make histogram from diff-output
+%define AppProgram diffstat
+%define AppVersion 1.55
+# $XTermId: diffstat.spec,v 1.3 2010/10/10 18:09:56 tom Exp $
+Name: %{AppProgram}
+Version: %{AppVersion}
+Release: 1
+License: MIT
+Group: Applications/Development
+URL: ftp://invisible-island.net/%{AppProgram}
+Source0: %{AppProgram}-%{AppVersion}.tgz
+Packager: Thomas Dickey <dickey@invisible-island.net>
+
+%description
+Diffstat is is useful for reviewing large, complex patch files. It reads from
+one or more input files which contain output from diff, producing a histogram
+of the total lines changed for each file referenced.
+
+%prep
+
+%setup -q -n %{AppProgram}-%{AppVersion}
+
+%build
+
+INSTALL_PROGRAM='${INSTALL}' \
+ ./configure \
+ --target %{_target_platform} \
+ --prefix=%{_prefix} \
+ --bindir=%{_bindir} \
+ --libdir=%{_libdir} \
+ --mandir=%{_mandir}
+
+make
+
+%install
+[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
+
+make install DESTDIR=$RPM_BUILD_ROOT
+
+strip $RPM_BUILD_ROOT%{_bindir}/%{AppProgram}
+
+%clean
+[ "$RPM_BUILD_ROOT" != "/" ] && rm -rf $RPM_BUILD_ROOT
+
+%files
+%defattr(-,root,root)
+%{_prefix}/bin/%{AppProgram}
+%{_mandir}/man1/%{AppProgram}.*
+
+%changelog
+# each patch should add its ChangeLog entries here
+
+* Thu Jul 15 2010 Thomas Dickey
+- initial version