aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorCameron Katri <me@cameronkatri.com>2021-03-31 08:49:50 -0400
committerCameron Katri <me@cameronkatri.com>2021-03-31 08:49:50 -0400
commita3225ce583b7138c5c939a1f91a6998d1cf77e4e (patch)
tree10772ce7d8eb8f98694dd9798e5ef226228a6120 /Makefile
parente7528f8ba630dfe4454d7668a9ee02589c00dfa6 (diff)
parent8d6d26bea0b0a02b1ec25e099f1c8878d5a1211a (diff)
downloadbsd-progress-debian-debian.tar.gz
bsd-progress-debian-debian.tar.zst
bsd-progress-debian-debian.zip
Update upstream source from tag 'upstream/9.99.81'debian/9.99.81-1debian-debian
Update to upstream version '9.99.81' with Debian dir 88c446da6f32af343e2e61ac4d27334f0f0437ec
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..cc9c47d
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,31 @@
+# $NetBSD: Makefile,v 1.2 2003/01/22 02:56:30 lukem Exp $
+
+PROG= progress
+SRCS= progress.c progressbar.c strsuftoll.c
+
+
+CPPFLAGS +=-Iinclude -DSTANDALONE_PROGRESS
+UNAME ?= $(shell uname)
+PREFIX ?= /usr
+PROG_PREFIX ?= bsd-
+
+ifeq ($(UNAME), Linux)
+ifeq ($(shell pkg-config libbsd-overlay && echo 1),1)
+ CPPFLAGS+=$(shell pkg-config libbsd-overlay --cflags)
+ LDFLAGS+=$(shell pkg-config libbsd-overlay --libs)
+endif # ($(shell pkg-config libbsd-overlay && echo 1),1)
+endif # ($(UNAME), Linux)
+
+all: $(PROG)
+
+$(PROG): $(SRCS:%.c=%.o)
+ $(CC) $(LDFLAGS) -o $@ $^
+
+install: $(PROG) progress.1
+ install -Dm755 $(PROG) $(DESTDIR)$(PREFIX)/bin/$(PROG_PREFIX)$(PROG)
+ install -Dm644 progress.1 $(DESTDIR)$(PREFIX)/share/man/man1/$(PROG_PREFIX)progress.1
+
+clean:
+ rm -f *.o $(PROG)
+
+.PHONY: all install clean